Nokia Suite 3.8 - What is .NET Framework 3 and why do I need it?

The Microsoft .NET Framework is a software framework available with several Microsoft Windows operating systems. Several versions have been released so far. The following Nokia software products require you to have the .NET Framework version 3 or higher installed: 

  • Nokia Suite - Microsoft .NET Framework version 3 or higher. It is available on your Nokia DVD. If you have Windows Vista, you already have this software available.
  • Nokia Music - Nokia Music requires two additional Windows components to be installed: .NET 3 and WMF 11. If you do not have these already they will be installed automatically.

If you do not have .NET Framework installed on your system, you can download it by accessing the following link:http://www.microsoft.com/en-us/download/details.aspx?id=21

Note: If you already have the .NET Framework 2.0 installed, the .NET Framework 3.0 redistributable package installs only the new Windows Vista components. This ensures that any .NET Framework 2.0-based applications work seamlessly when the .NET Framework 3.0 is installed, with no application migration or updates of any kind required.