How do I turn off the vibration for hard-key touches?

Navigate to Settings > Sound > Advanced > Vibrate on tap